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About This Guide

In this User’'s Manual, it is assumed that the user is familiar with the
Microsoft Windows operating environment. This includes an understanding on
how to:

1. Use a mouse or other pointing device to click, double click, drag and
select information

Scroll using scrollbars

Open and close program in Microsoft Windows

Type using a computer keyboard
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Navigate or selecting menus and submenus

It is also assumed that the user is familiar in microcontroller programming
either in C or assembly language. The user must have knowledge on
compiling/debugging source codes and is well aware of some electronic terms
and numbering system. Moreover, it is also assumed that the user is
knowledgeable on the standards and safety precautions in operating

electronics hardware and correct handling of microcontrollers.
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I. Overview

This user manual will guide you in using ALEXAN ATMEL Device Programmer

Software.

This software can program the ATMEL AT89C2051 and AT89C4051

microcontroller.

It has a comprehensive set of features that allows you to view, program,

erase and secure the data of an ATMEL microcontroller. Equipped with a

computer-interface, the computer-interface software allows you to:

1. Load or open hex files containing the code you want to program to the
device.

2. Read the hex code from the device and store it in the program buffer for
editing or saving.

3. View and edit the hex codes in the program buffer.

4. Save any changes made in the program buffer to a hex file for use with

other devices.

Check the device ID.

Erase all the data in the device.

Blank check the device.

Program the hex codes found in the program buffer to the device
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Verify the programmed hex code in the device
10.Protect the device from accidentally reprogramming by locking the device

so that the code cannot be read from it.

For more information about ATMEL microcontroller, please visit ATMEL’s

website at http://www.atmel.com to download datasheet and technical

notes.
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I1. Installation

To install the ALEXAN ATMEL Programmer computer-interface, do the

following:

1. Insert the CD containing the ALEXAN ATMEL Programmer into the CD-
ROM.

2. Run the setup.exe file.

3. Follow the instructions given during setup.

4. After the installation is finished, click ok.

5. To run the ALEXAN ATMEL Programmer, go to:

Start 2> Programs > ALEXAN ATMEL Programmer

111. Getting Started

What You Need To Get Started

1. Personal Computer with CD-ROM and serial or USB port

2. ALEXAN ATMEL Programmer Software

ALEXAN ATMEL Programmer Module

RS232 Serial Cable Or a USB to COM/Serial cable.

12 to 16Vdc Power Adaptor

AT89C2051 or AT89C4051 ATMEL Microcontroller (or MCU)

N o o kw0

Any debugger/compiler software where you can write your source code
and compile it to a hex file format

8. a Hex file
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1V. ALEXAN ATMEL Programmer Module

RS232 connection; Must be
connected to the computer
using serial cable.

DC Jack for 12 to
18Vdc 500mA Adaptor

Busy LED; Blinks during
programming.

Power
Indicator

This lever must be
lowered down during
programming to hold
the MCU in place.

gRpIvn

ZIF socket. Insert your MCU here. Pins 10 and 11 of MCU
(located at lower bottom) must be connected to the bottom-
most pins of the ZIF socket (pin 12 & 13).
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V. ALEXAN ATMEL Programmer Computer-
Interface Software
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Figure 5.1: Programmer Computer-Interface Software

Once the program has been successfully installed, you are ready to run the
program. After starting the programmer software, you will see the window as
shown in Figure 5.1. Menus and submenus, toolbar buttons and shortcut

keys are provided for ease of navigation.
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V1.

How To Program A Device

To program a device, do the following:

1.
2.

Connect the Programmer module to the serial port of your computer.

Plug the DC jack of the adaptor to the Programmer module then plug the
adaptor to the AC outlet to turn on the power.

Insert the AT89C2051 or AT89C4051 device to program in the ZIF socket

of the Programmer module.

4. Run the ALEXAN ATMEL PROGRAMMER software.

At startup of the software, it will automatically search for and connect to

the serial port the Programmer module is connected to.

Alternately, you may select the serial port to connect to by selecting the
Serial Port Setup (press F9). After selecting the appropriate COM port,
press OK. The programmer will then search for your Programmer module.
If a connection failure occurs, either you do not have a COM port available

or another application is using the COM port you selected.

. Click 1C(89C2051) (press F11) to program AT89C2051 MCU or

IC(89C4051) (press F12) to program AT89C4051 MCU. Make sure that
the selected IC in the software matches that of the IC you have inserted
in the Programmer module.

Open a hex file (*.hex). On the File menu, click Open File. Make sure
that your compiler generates a hex file from your source code since the
programmer will only allow a valid hex file format with a *.hex extension

to be opened.

. To view the hex codes, on the View menu, click Edit/View Buffer (press

F2).
To edit the programmer buffer, click the desired address and change the

value that you want by typing any hex values from 00 to FF.

10.To save the codes in the program buffer to a hex file, on the File menu,

click Save File (press CTRL+S).

11.To program, on the Tools menu, click Program Device (press F5).
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A form is displayed as shown in Figure 6.1. It contains an auto program
function where you can still check and uncheck programming options

available. Go to Chapter 6 for the detailed description of each option.

Click Run to start programming.

- Program Device - ATMIL BRCZ051 E

Select any options amd click RN STALT =

Cacactwuid ot COM pocz O

=) 10 Eheack ID Theck ORI
Ermee OKI

e Elaxm Chaok OEF
Feogean OK|
Tard by OH1

# Erase Device Locibit | O
Lockbait I OKI

= Blank Chack TN

= Prodgram

% verlty

R Lockhbit 1

F Lockbir 2

Check 8l Uncheck all

Figure 6.1: Program Device Form
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V1l.Programming Options

ID Check
AT89C2051 and AT89C4051 is the only recognized MCU and each has

its unique ID. The 1D Check option will verify if you have inserted a
correct MCU to your Programmer module. Make sure that the device
you have selected in the Programmer software must match with the
one you are programming. In cases where the ID code of your MCU
has been damage, you can still program by unchecking this option.
Erase Device
The Erase Device option will erase the entire PEROM (Programmable
Erasable Read Only Memory) array of your MCU.
Blank Check
The Blank Check option will check if the entire PEROM array has been
erased.
Program
The Program option will write the hex codes in the software’s
programmer buffer into your microcontroller.
Verify
The Verify option will check if the microcontroller has the same hex
codes with that of the programmer buffer’'s hex codes.
Lockbit 1
The Lockbit 1 option will protect your MCU from reprogramming. The
microcontroller cannot be reprogrammed unless it is erased first.
Lockbit 2
The Lockbit 2 option will hide the data bytes of your microcontroller.
It is used for security purposes so that other users cannot copy what is
inside your MCU. Take note that Lockbit 2 requires that you select also

Lockbit 1.
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VII11.Other Features

Read Device
If you want to know what is programmed in the MCU, you can read
and view the data bytes for each address - O0Oh to 7FFh for AT89C2051
and 00h to FFFh for AT89C4051). On the Tools menu, click Read

Device (press F4). A form is displayed as shown in Figure 8.1.

Select Run start reading. You can uncheck the ID Check box if the ID
code of your MCU is damage. Open the programmer buffer to view the

read data.

/- Read Device - ATMEL B9C2051 X

Select any options and click BN

Check all  Uncheck all

Figure 8.1: Read Device Form

Compare

The Compare option allows you to see the differences between the
data byte written in your MCU and the data bytes currently loaded in
the programmer buffer. The programmer will read the entire PEROM
array of your MCU and, then, compare it with the data on the
programmer buffer. All differences will be displayed in the grid as

shown in Figure 8.2.
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To save the differences, click Save to File. The file is saved in a text
file format (*.txt format) containing the difference between the device

data and programmer buffer data together with its address.

Cormpare Programmes Buffer and Device Data = |0([

Addr | Buffnr Dats | <=> | Bavice Dats

Figure 8.2: Compare Device Form

Unused Bytes

Default unused bytes set is 00. To change the unused bytes between
00 and FF, go to Settings menu, then, select Unused Bytes. Click 00
(press CTRL+F1) or FF (press CTRL+f2) for the desired unused bytes

to use.
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1X. Troubleshooting

Invalid Hex File!

Read File Error rsz|

@ Invalid Hex File!

This occurs if the hex file you are attempting to load is not a valid hex
file.

Programmer Missing!

- Program Dewvice - ATMEL BRCKIST

Select any opfions ad olick BUN: [ ATART =
Frograsssy sissing!

I« 1D Clheick ———m AN ———-

¥ Erase Devics

I Blank Chock

¥ Progrom
= varity
Select Serial Port: ¥ Lockhit 1
T EOM3 ¥ Lockhit 2
T oose Class | Check all  Uncheck Al
ATMEL Programmar missing al COMZ!

This occurs if: (1) Programmer module is turned off; (2) serial cable is
not connected and/or is damage; or (3) other application is using the
same COM port. Configure your serial port so that during programming

it can be used only by the Programmer software and is located
between COM1 to COMA4.
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ID Check Failed!

= Program Device - ATMEL B9C2051

Select any options and click BUN:  |————- START —-——-
Detected at COM port Z
¥ ID Check IL Check FAILED!
_____ EN‘D —————
R

¥ Erase Device
¥ Blank Check
¥ Program

¥ Verify

¥ Lockbit 1

¥ Lockbit 2

Check all  Uncheck all

Check if the MCU you selected in the ATMEL Device Use option is the

same with the MCU that you have inserted in your programmer
module. Check for the correct insertion of the MCU. Check if the ZIF

socket knob has been locked.

Program Failed!

- Propram Device - ATRIL B5CAF51 EI
Select any options and ciick Btiv: [ FTART ——ees
[becercad wc COM pors 1
[ 10 Check |Keasa 0K

|Eiank Chach OHi
I |Frogoes FATLED|
EHD

F Erasa Device
¥ Blank Check
¥ Prodgram

F Varify
 Lockhit 1

¥ Lockhit 2

Chack a0 Wischack AT
| Rt |

Check if the power is turned on. Make sure the MCU is inserted

properly into the ZIF socket. Reinsert MCU if necessary.
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Verify Failed!

+ Program Device - ATMEL B9C2051

Select any options and cfick BUN: | ————- START —--—--
Detected at COM port 2
7 ID Check Erase OE!
Elank Check 0!
il ] g Program OK!
— St Verify FAILED!
R EEE END —--—--
¥ Erase Device
¥ Blank Check
¥ Program
v Werify
I+ Lockbit 1
I+ Lockbit 2

Check all Uncheck all

Be sure that the ZIF lever is in lock position. Check if the power is
turned on. Check if the MCU is inserted properly. Make sure that the
serial cable is working properly. Reconnect MCU and program again.
Please note that if the MCU has reached its 1,000 erase/write cycles, it
can no longer be programmed. In some other cases, MCU had been
damage, and therefore it is not capable of reprogramming. Check the

ATMEL datasheets for the correct handling of your MCU.
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